Freeloader Gets Blocked
Posted by on March 24th, 2008

A second update for the Nintendo Wii was released yesterday in North America – and unfortunately it blocks the popular Freeloader, used by so many owners.

Freeloader is an unofficial bootdisc that lets you bypass region locking for Wii games. It also works with some imported GameCube games.

WiiBrew.org explains what the update actually means:

On March 21st, Nintendo added a new version of the Wii firmware — IOS37 — to the Wii update servers. This version of the firmware has a fixed signature-checking function.

Simplification for those who don’t understand what’s written below:

  1. The latest update only includes IOS37.
  2. The system menu currently doesn’t use this IOS37.
  3. The signing bug is still effective.
  4. The only reason this info is public is because we’re watching Nintendo closely. It does not affect you.

When a title (game, channel, etc) starts, it tells the system menu (using a field in the TMD) what version of the IOS it needs to run on — to support this, the Wii stores all previous firmware versions. (For most Wiis, this will be IOS9, IOS11, IOS13, IOS15, IOS17, IOS20, IOS21, IOS30, IOS31, IOS33, IOS34, IOS35, IOS36, and now IOS37).

As of March 22nd, no software uses IOS37 — the System Menu currently uses IOS30. An updated System Menu will likely use the new IOS37.

What does this mean?

  • Once the system menu is updated to use IOS37, “Trucha-Signed” discs — or channels — will stop working, as will the Datel FreeLoader disc. This has been confirmed.
  • At that point, “homebrew channels” would be considered “invalid” by the system. marcan now contends that having one installed and going to an update using IOS37 will brick your Wii, giving a “The system files are corrupted” message.
    <marcan> I just performed some magic and confirmed that having the homebrew channel installed and installing an update to the system menu that uses the IOS37 will brick your wii, unless Nintendo specifically addresses this problem in a new system menu. There is a simple way of avoiding this: simply delete the channels before updating.
  • Other versions of IOS are not affected.
  • To sum all this up, the update will NOT break anything. The latest update does not actually use IOS37, so updating will be safe until a future update is released.
Byakuya avatar

Byakuya

Former author at Akayuki.com.

DreamFlask.com / Akayuki Archives / Freeloader Gets Blocked